前の日 / 次の日 / 最新 / 2005-04

sleepin' with the daemon - でーもん君と眠る日々 - / 2005-04-12

01 02 03 04 05 06 07 08 09 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30

2005-04-12 Tue

ntpd が動かない。 [自宅サーバ]

新サーバにしてから、ntpd を起動すると一応デーモンは立ち上がってい るようなのに、起動時に
ntpd[80407]: bind() fd 8, family 2, port 123, addr 0.0.0.0, in_classd=0 flags=25 fails: Address already in use
と言われてて、正常に時刻の同期が出来ていなかった。 "Address already in use" なんて言われても、ntpd が複数立ち上がって いるわけでも、先にこのアドレス(0.0.0.0)を握ってるプロセスがいるわ けでもなく、わけわからん。

旧サーバとの違い といえば、ntpd のバージョンくらいか。

旧サーバ: ntpd 4.1.0-a
現サーバ: ntpd 4.2.0-a(FreeBSD 5.3-RELEASE付属)

いろいろ調べてると、なんか ntpd が socket を bind する動作が変わっ ている模様。 4.1.0-a では、"*:123"という風にIPアドレスはワイルドカードで bind してるけど、4.2.0-a では、ワイルドカードの他にネットワークデバイス に振られてるアドレスすべてに bind しようとしている。
で、PPPoE 用に使っていたネットワークデバイス(fxp1)に 0.0.0.0 を振っ ていたのだが 4.2.0-a ではこれがマズイようで("*:123"と当る)、アド レス(0.0.0.0)を振らないようにしたら問題なく動作するようになった。

ちなみに ntp のスナップショットでも 4.2.0-a と同じ動き。ntp の Bugzilla には、bind するIPアドレスを指定出来るオプションを追加 するパッチが投げられてたが取り込まれてはいない模様。

ハードディスク壊れた。 [自宅サーバ]

前からポロポロとエラー吐いてたのをだましだまし使ってたんだけど酷く なってきたのでマシンごと入れ替え。
バックアップ取ってなかった(前からエラー吐いてるのに取っておけよ > オレ)ので半泣きになりながら(メールは IMAP でサーバに溜込んでたし) とりあえずデータのサルベージ。
デーモンいろいろ立ち上げの途中で突然リブートしたりで半ば諦めモード だったけど、要らんもん立ち上げないようにしたらなんとかOS起動。
腫れ物に触るがごとく、恐る恐るメールや各種設定ファイルやらなん とか救出してから、前からリプレイス用に買ってた(けど放置されてた)マ シン(EPIA Mini-ITX 1G ののった Hush Technology のやつ)に移行。

2011 : 01 02 03 04 05 06 07 08 09 10 11 12
2010 : 01 02 03 04 05 06 07 08 09 10 11 12
2009 : 01 02 03 04 05 06 07 08 09 10 11 12
2008 : 01 02 03 04 05 06 07 08 09 10 11 12
2007 : 01 02 03 04 05 06 07 08 09 10 11 12
2006 : 01 02 03 04 05 06 07 08 09 10 11 12
2005 : 01 02 03 04 05 06 07 08 09 10 11 12
2004 : 01 02 03 04 05 06 07 08 09 10 11 12
2003 : 01 02 03 04 05 06 07 08 09 10 11 12

最終更新時間: 2012-08-29 17:42